Copyright © 2016
NETcellent System, Inc
4030 Valley Blvd. Suite 100
Walnut, CA 91789-0931




 

Version 7.5 Downloads

The following file contains current updates for ELLIOTT V7.5 



Warning:
Do not download this update if your maintenance expiration date is earlier than 3/22/17. If you install this update with a maintenance expiration date on or before 3/22/17, then you will not be able to run Elliott after the installation.
Elliott v7.5 requires PSQL 10 or higher to run. If you have an older version of PSQL, you will need to upgrade to PSQL 10 or higher before installing the v7.5 update. Contact your reseller or Netcellent to upgrade to the latest PSQL version.

Tips for updating Elliott: When you run the Elliott eli75up.exe update package, you must ensure all users exit Elliott first. When installation is complete, if you are asked to "Reboot" your machine the installation was not entirely successfull because files were opened by users. This type of inconsistent update may cause un-predictable errors. You must ensure all users have exited Elliott and try the update again, until it is successful.

Note: This update supports the 2013 Medicare Additional Tax for Payroll tax calculation. For detail information regarding this upate, click here.


Update release equivalent to V7.57.322

eli75up.exe - Elliott v7.5 update program. Updated on 3/22/17.
Elliott v7.5 upgrade instruction for 7.0/7.1/7.2/7.3/7.4 users
What's New in Elliott v7.5?
View or download Elliott release notes


If you have any questions regarding the program updates or downloading and applying the updates, please contact our Elliott Support Team.